Environment
ZENworks 24.2
ZENworks MDM and Exchange ActiveSync
Situation
After updating from ZENworks 23.4 to 24.2, the ActiveSync functionality stops working for all enrolled mobile devices when using ZENworks proxy as part of Email policy . It impacts email synchronization for all mobile devices using ActiveSync
No events are logged during as part of mobile device email synchronization request into client-mgmt/services-messages.log on MDM Server due to below error
Check /var/opt/microfocus/log/zenworks/api-gateway/api-gateway-spring-framework.log for any 403 Forbidden error message:
[DEBUG] [2024-10-10 08:50:31] [reactor-http-epoll-1] [8] [Api-Gateway] [32] [HttpWebHandlerAdapter] [[8dea060c-37891] HTTP OPTIONS "/Microsoft-Server-ActiveSync"]
[DEBUG] [2024-10-10 08:50:31] [reactor-http-epoll-1] [8] [Api-Gateway] [32] [RoutePredicateHandlerMapping] [Route matched: client_service_route]
[DEBUG] [2024-10-10 08:50:31] [reactor-http-epoll-1] [8] [Api-Gateway] [32] [RoutePredicateHandlerMapping] [Mapping [Exchange: OPTIONS https://ZEN_MDM_Server/Microsoft-Server-ActiveSync] to Route{id='client_service_route', uri=https://ZEN_MDM_Server:7491, order=0, predicate=Paths: [/**], match trailing slash: true, gatewayFilters=[[[PreserveHostHeader], order = 1], [com.microfocus.zenworks.apigateway.filter.security.mdmfilter.MDMAccessFilter$$Lambda$862/0x00000001007ac040@cd5385e, order = 2]], metadata={}}]
[[GatewayFilterAdapter{delegate=org.springframework.cloud.gateway.filter.RouteToRequestUrlFilter@2ba33e2c}, order = 10000],
[DEBUG] [2024-10-10 08:50:31] [reactor-http-epoll-1] [8] [Api-Gateway] [32] [HttpWebHandlerAdapter] [[8dea060c-37891] Completed 403 FORBIDDEN]
ZENworks Client Management unable to process API requests to Microsoft-Server-ActiveSync web application, returning a 403 Forbidden error.
Cause
The issue occurred because the HTTPMethodSettingConfigureAction configuration action was not executed during the system update to ZCM 24.2. This resulted in ActiveSync API requests being forbidden.
Resolution
The issue has been reported to engineering.
As a workaround to resolve this issue, follow the below steps:
- Manually execute below command on the ZENworks MDM Primary Server:
microfocus-zenworks-configure -c HTTPMethodSettingConfigureAction
- Restart the microfocus-zenclient-mgmt.service by using the below command:
systemctl restart microfocus-zenclient-mgmt.service
- Verify that the communication between the mobile devices and the configured ActiveSync Exchange is established and emails are synchronized correctly